Ruby on Rails Set-up on Silver

Installed latest Ruby using MacPorts (I had installed previously):

Install Ruby, itself

$ sudo port install ruby

(installed @1.8.7-p174
included:
  • gperf 3.0 — GNU perfect hash generator
  • libiconv 1.13.0 — Character set conversion library
  • ncursesw 5.7 — terminal emulator (for writing TUIs)
  • zlib 1.2 — zlib lossless data-compression library
  • openssl 0.9 —
  • readline 6.0 —

Install RubyGems

Then, I installed RubyGems:

$ sudo port install rb-rubygems

(installed @1.3.7; Proceeded to upgrade to the latest of the same libs just installed)

  • libiconv 1.13.1
  • readline 6.1
  • zlib 1.2.5
  • openssl
  • readline
  • ruby1.8.7-p302
$ sudo port -u uninstall

(uninstalls all inactive ports… handy!)

I had to restart my terminal window to see the new "gem" executable (installed by ports)

I installed the gems for "rails 2.3.9" (the latest 2.x version of rails):

1. went to http://rubygems.org/gems/rails/versions
2. found my version and clicked; ran the gem install with the right version (sudo required)

silver:~ john$ sudo gem install rails -v 2.3.9¡
Password:
Successfully installed rake-0.8.7
Successfully installed activesupport-2.3.9
Successfully installed activerecord-2.3.9
Successfully installed rack-1.1.0
Successfully installed actionpack-2.3.9
Successfully installed actionmailer-2.3.9
Successfully installed activeresource-2.3.9
Successfully installed rails-2.3.9
8 gems installed
Installing ri documentation for rake-0.8.7...
Installing ri documentation for activesupport-2.3.9...
Installing ri documentation for activerecord-2.3.9...
Installing ri documentation for rack-1.1.0...
Installing ri documentation for actionpack-2.3.9...
Installing ri documentation for actionmailer-2.3.9...
Installing ri documentation for activeresource-2.3.9...
Installing ri documentation for rails-2.3.9...
Installing RDoc documentation for rake-0.8.7...
Installing RDoc documentation for activesupport-2.3.9...
Installing RDoc documentation for activerecord-2.3.9...
Installing RDoc documentation for rack-1.1.0...
Installing RDoc documentation for actionpack-2.3.9...
Installing RDoc documentation for actionmailer-2.3.9...
Installing RDoc documentation for activeresource-2.3.9...
Installing RDoc documentation for rails-2.3.9...

Start-up the Document Server

$ gem server

Watching: http://www.pragprog.com/wikis/wiki/ChangesInRails23

for Rails 2.3 errata (book is written against rails 2.2)

get Text Mate for rails screencast?

http://peepcode.com/products/textmate-for-rails-2

Installing git

(+'s are "variants")

sudo port install git-core +svn +doc +bash_completion

To fully complete your installation and make python 2.6 the default, please
run:

$ sudo port install python_select
$ sudo python_select python26

Installed TextMate Bundle for Rails 2.x

http://github.com/drnic/ruby-on-rails-tmbundle

Unless otherwise stated, the content of this page is licensed under Creative Commons Attribution-ShareAlike 3.0 License